Home » Database is in compatibility range – an upgrade is recommended

Database is in compatibility range – an upgrade is recommended

Problem:

Getting the following error “Database is in compatibility range and upgrade is recommended.”

Cause:

In my case, it was because I ran the SharePoint Cumulative Update before running the Foundation Cumulative Update. As this was just my development box, I wound up reinstalling. Always install the Foundation CU first. Restart. Run the PSConfig. If it’s too late for that advice, you can try the solution below, which successfully updated my content databases. I’ve included a couple lines of code that I used to do that. This page offers more about the error.

Does this work for non-content databases?

This should work for content databases:

One comment

  1. CB says:

    I can run the first part – Get-SPDatabase, but I get ‘not recognized as the name of a cmdlet’ for Upgrade-SPDatabase
    (Upgrade-SPContentDatabase works fine)

    Any ideas?

Leave a Reply

Your email address will not be published. Required fields are marked *

*